Re: Newbie back again...

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Newbie back again...

Patryk Laurent

I can confirm that for a successful GNUstep build on Ubuntu 16.04, it is sufficient to check out the older version of GNUstep Make -- no need to check out older versions of the other repositories.  

openapp ./GUITest worked without crashing.

Patryk



On Apr 23, 2017, at 04:22 PM, Josh Freeman <[hidden email]> wrote:

Sorry, the git checkout command for workaround #2 in my previous
message is missing "master" at the end:


git checkout `git rev-list -1 --first-parent --before=2017-04-06`

should be:

git checkout `git rev-list -1 --first-parent --before=2017-04-06 master`


On Apr 23, 2017, at 6:34 PM, Josh Freeman wrote:

2) Build with an earlier version of make (though this will break
ARC): In the build script, after changing to the make directory, but
before configuring make (the first time it's built), add a git
checkout command to force it to use a source-tree snapshot from
before April 7:

...
cd make
git checkout `git rev-list -1 --first-parent --before=2017-04-06`
./configure --enable-debug-by-default --with-layout=gnustep --enable-
objc-nonfragile-abi --enable-objc-arc
...


_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep