SimpleAgenda on FreeBSD

classic Classic list List threaded Threaded
22 messages Options
12
Reply | Threaded
Open this post in threaded view
|

SimpleAgenda on FreeBSD

edwin ancaer
Hello all, 

I installed the package forSimpleAgenda on FreeBSD, but I have some problems with it.

The application  displays well, but when I try to add a new appointment, the only things I can do are
add the title,
set the repetition factor and click the  button to initialize the until date,
click the alarm button (but filling in the alarm is also not completely working)

I cannot
change the hour / duration with the slide bars,
enter a location, 
change the until date
select a store,
enter a description

The first time I try to do one of the 'forbidden things', I get a message
in the log:
2018-06-25 04:27:41.934 SimpleAgenda[1861:100298] Problem posting notification: <NSException: 0x2c7f7530> NAME:NSInvalidArgumentException REASON:AppointmentEditor(instance) does not recognize document INFO:(null)

It only appears once, and afterwards, everything continues to partially work.
The same kind of error happens for the creation of an event.

I updated all packages and tried a new install, but the result remains the same. The installed package has release 43. 

[edwin@ottopedi ~]$ uname -a
FreeBSD ottopedi 11.1-RELEASE-p1 FreeBSD 11.1-RELEASE-p1 #0: Wed Aug  9 11:17:49 UTC 2017     [hidden email]:/usr/obj/usr/src/sys/GENERIC  i386

Anybody experienced similar problems? Could this be linked to missing components in my installation? 

Kind regards,
Edwin Ancaer.



_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

kanzlei

i want to be removed from this mailig list with all adresses of the domain txt.de. Can you help, please?

Kind regards

Edwin Ancaer <[hidden email]> hat am 26. Juni 2018 um 10:19 geschrieben:

Hello all, 

I installed the package forSimpleAgenda on FreeBSD, but I have some problems with it.

The application  displays well, but when I try to add a new appointment, the only things I can do are
add the title,
set the repetition factor and click the  button to initialize the until date,
click the alarm button (but filling in the alarm is also not completely working)

I cannot
change the hour / duration with the slide bars,
enter a location, 
change the until date
select a store,
enter a description

The first time I try to do one of the 'forbidden things', I get a message
in the log:
2018-06-25 04:27:41.934 SimpleAgenda[1861:100298] Problem posting notification: <NSException: 0x2c7f7530> NAME:NSInvalidArgumentException REASON:AppointmentEditor(instance) does not recognize document INFO:(null)

It only appears once, and afterwards, everything continues to partially work.
The same kind of error happens for the creation of an event.

I updated all packages and tried a new install, but the result remains the same. The installed package has release 43. 

[edwin@ottopedi ~]$ uname -a
FreeBSD ottopedi 11.1-RELEASE-p1 FreeBSD 11.1-RELEASE-p1 #0: Wed Aug  9 11:17:49 UTC 2017     [hidden email]:/usr/obj/usr/src/sys/GENERIC  i386

Anybody experienced similar problems? Could this be linked to missing components in my installation? 

Kind regards,
Edwin Ancaer.


_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

Liam Proven
On Tue, 26 Jun 2018 at 10:23, <[hidden email]> wrote:
>
> i want to be removed from this mailig list with all adresses of the domain txt.de. Can you help, please?

[1] Don't hijack someone else's thread. That is bad manners.

[2] Read the signature of any email you get from the list.

--
Liam Proven - Profile: https://about.me/liamproven
Email: [hidden email] - Google Mail/Hangouts/Plus: [hidden email]
Twitter/Facebook/Flickr: lproven - Skype/LinkedIn: liamproven
UK: +44 7939-087884 - ČR (+ WhatsApp/Telegram/Signal): +420 702 829 053

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

p.o.roussel
In reply to this post by edwin ancaer
[Sorry for top posting, crappy web interface]

Hi Edwin,

What version of SimpleAgenda is this ? I think I have fixed these problems few months ago but can't remember if I did a release..

Thanks,
Philippe

----- Mail original -----
De: "Edwin Ancaer" <[hidden email]>
À: "Discuss GNUstep" <[hidden email]>
Envoyé: Mardi 26 Juin 2018 10:19:22
Objet: SimpleAgenda on FreeBSD





Hello all,



I installed the package forSimpleAgenda on FreeBSD, but I have some problems with it.


The application displays well, but when I try to add a new appointment, the only things I can do are

add the title,

set the repetition factor and click the button to initialize the until date,
click the alarm button (but filling in the alarm is also not completely working)


I cannot

change the hour / duration with the slide bars,

enter a location,
change the until date

select a store,
enter a description


The first time I try to do one of the 'forbidden things', I get a message

in the log:

2018-06-25 04:27:41.934 SimpleAgenda[1861:100298] Problem posting notification: <NSException: 0x2c7f7530> NAME:NSInvalidArgumentException REASON:AppointmentEditor(instance) does not recognize document INFO:(null)


It only appears once, and afterwards, everything continues to partially work.
The same kind of error happens for the creation of an event.


I updated all packages and tried a new install, but the result remains the same. The installed package has release 43.



[edwin@ottopedi ~]$ uname -a
FreeBSD ottopedi 11.1-RELEASE-p1 FreeBSD 11.1-RELEASE-p1 #0: Wed Aug 9 11:17:49 UTC 2017 [hidden email]:/usr/obj/usr/src/sys/GENERIC i386


Anybody experienced similar problems? Could this be linked to missing components in my installation?


Kind regards,
Edwin Ancaer.





_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

edwin ancaer
Philippe,

The Info panel says it's 0.43. That is also the current version on wiki.gnustep.org. But I saw that on github, there is a version 44 indeed. I think that I should ask the maintainer of the port to update to the new version , if that is ok for you.

Apparently I'm a top poster also. I never gave much thought to it, it's what gmail does automatically. If it is considered badd manners, I'll have to do something about it.

Thanks a lot

Edwin Ancaer


1 di 26 jun. 2018 12:03 schreef <[hidden email]>:
[Sorry for top posting, crappy we1b interface]

Hi Edwin,

What version of SimpleAgenda is this ? I think I have fixed these problems few months ago but can't remember if I did a release..

Thanks,
Philippe

----- Mail original -----
De: "Edwin Ancaer" <[hidden email]>
À: "Discuss GNUstep" <[hidden email]>
Envoyé: Mardi 26 Juin 2018 10:19:22
Objet: SimpleAgenda on FreeBSD





Hello all,



I installed the package forSimpleAgenda on FreeBSD, but I have some problems with it.


The application displays well, but when I try to add a new appointment, the only things I can do are

add the title,

set the repetition factor and click the button to initialize the until date,
click the alarm button (but filling in the alarm is also not completely working)


I cannot

change the hour / duration with the slide bars,

enter a location,
change the until date

select a store,
enter a description


The first time I try to do one of the 'forbidden things', I get a message

in the log:

2018-06-25 04:27:41.934 SimpleAgenda[1861:100298] Problem posting notification: <NSException: 0x2c7f7530> NAME:NSInvalidArgumentException REASON:AppointmentEditor(instance) does not recognize document INFO:(null)


It only appears once, and afterwards, everything continues to partially work.
The same kind of error happens for the creation of an event.


I updated all packages and tried a new install, but the result remains the same. The installed package has release 43.



[edwin@ottopedi ~]$ uname -a
FreeBSD ottopedi 11.1-RELEASE-p1 FreeBSD 11.1-RELEASE-p1 #0: Wed Aug 9 11:17:49 UTC 2017 [hidden email]:/usr/obj/usr/src/sys/GENERIC i386


Anybody experienced similar problems? Could this be linked to missing components in my installation?


Kind regards,
Edwin Ancaer.





_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

Liam Proven
On Tue, 26 Jun 2018 at 14:49, Edwin Ancaer <[hidden email]> wrote:
>
> Apparently I'm a top poster also. I never gave much thought to it, it's what gmail does automatically. If it is considered badd manners, I'll have to do something about it.

It's very easy. Hit Ctrl-A to select all text; this expands the quoted
message. Cursor past it, trim as appropriate, reply below. This is
exactly what I just did.

On mailing lists, one should always bottom-post, as a general rule. I
personally hate top-posting. As the famous sig goes:

         A: Yes.
     >   Q: Are you sure?
     >>  A: Because it reverses the logical flow of conversation.
     >>> Q: Why is top posting frowned upon?


--
Liam Proven - Profile: https://about.me/liamproven
Email: [hidden email] - Google Mail/Hangouts/Plus: [hidden email]
Twitter/Facebook/Flickr: lproven - Skype/LinkedIn: liamproven
UK: +44 7939-087884 - ČR (+ WhatsApp/Telegram/Signal): +420 702 829 053

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

p.o.roussel
In reply to this post by edwin ancaer
----- Mail original -----
>
> Philippe,
>
>
> The Info panel says it's 0.43. That is also the current version on
> wiki.gnustep.org . But I saw that on github, there is a version 44
> indeed. I think that I should ask the maintainer of the port to
> update to the new version , if that is ok for you.

It is indeed ok with me, I just didn't take the time to make an official release and update the wifi.

Let me know if 0.44 fixes your problems.

Thanks, Philippe

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

edwin ancaer


2018-06-26 23:24 GMT+02:00 <[hidden email]>:
----- Mail original -----
>
> Philippe,
>
>
> The Info panel says it's 0.43. That is also the current version on
> wiki.gnustep.org . But I saw that on github, there is a version 44
> indeed. I think that I should ask the maintainer of the port to
> update to the new version , if that is ok for you.

It is indeed ok with me, I just didn't take the time to make an official release and update the wifi.

Let me know if 0.44 fixes your problems.

Thanks, Philippe


Hello,

I downloaded the new version but now I have a problem with the configuration step of the new version.

checking libical/ical.h usability... no
checking libical/ical.h presence... no
checking for libical/ical.h... no
checking ical.h usability... no
checking ical.h presence... no
checking for ical.h... no
configure: error: ical.h not found. You must have libical >= 0.27 installed.
GNUmakefile:2: local.make: No such file or directory


when looking for ical.h, it is found in /usr/local/include/:

[edwin@ottopedi ~/Objc/SimpleAgenda/simpleagenda-master]$ locate ical.h
/usr/local/include/libavutil/spherical.h
/usr/local/include/libical/ical.h
/usr/local/include/postgresql/server/replication/logical.h

 
How can I make the configure step look for ical.h in /usr/local/include/?

Thanks in avance

Edwin Ancaer

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

p.o.roussel
> Hello,
>
>
>
> I downloaded the new version but now I have a problem with the
> configuration step of the new version.
>
>
>
> checking libical/ical.h usability... no
> checking libical/ical.h presence... no
> checking for libical/ical.h... no
> checking ical.h usability... no
> checking ical.h presence... no
> checking for ical.h... no
> configure: error: ical.h not found. You must have libical >= 0.27
> installed.
> GNUmakefile:2: local.make: No such file or directory

This is your first problem : you should source GNUstep.h to configure your environment before anything else.

Thanks,
Philippe

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

Ivan Vučica-2
Did this help?

If not, a hacky thing I would do is, I would try:
  CFLAGS="-isystem /usr/local/include" ./configure
instead.

(Possibly also CXXFLAGS, OBJCFLAGS, and set up a library search path
with -L/usr/local/lib in LDFLAGS as well.)
On Thu, Jun 28, 2018 at 10:01 AM <[hidden email]> wrote:

>
> > Hello,
> >
> >
> >
> > I downloaded the new version but now I have a problem with the
> > configuration step of the new version.
> >
> >
> >
> > checking libical/ical.h usability... no
> > checking libical/ical.h presence... no
> > checking for libical/ical.h... no
> > checking ical.h usability... no
> > checking ical.h presence... no
> > checking for ical.h... no
> > configure: error: ical.h not found. You must have libical >= 0.27
> > installed.
> > GNUmakefile:2: local.make: No such file or directory
>
> This is your first problem : you should source GNUstep.h to configure your environment before anything else.
>
> Thanks,
> Philippe
>
> _______________________________________________
> Discuss-gnustep mailing list
> [hidden email]
> https://lists.gnu.org/mailman/listinfo/discuss-gnustep

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

Riccardo Mottola-5
Hi,

On 2018-07-12 10:09:04 +0000 Ivan Vučica <[hidden email]> wrote:

> Did this help?
>
> If not, a hacky thing I would do is, I would try:
>   CFLAGS="-isystem /usr/local/include" ./configure
> instead.
>
> (Possibly also CXXFLAGS, OBJCFLAGS, and set up a library search path
> with -L/usr/local/lib in LDFLAGS as well.)
> On Thu, Jun 28, 2018 at 10:01 AM <[hidden email]> wrote:

I just tried myself building SimpleAgenda on FreeBSD.

it states:
  --with-ical-include=DIR include path for ical headers
  --with-ical-library=DIR library path for ical libraries

but they do not work, I fixed the configure.ac script to properly work.
Philippe, do you like it? please apply it!

One may criticize that this is not an "optional package" configuration, since ical is required and we are abusing of AC_ARG_WITH, however, at least it works.
Maybe there is a more proper AC macro?

Also, I format the help string correctly now.

Riccardo

<ical_opts.patch>

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep

ical_opts.patch (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

edwin ancaer
In reply to this post by p.o.roussel


2018-06-28 11:00 GMT+02:00 <[hidden email]>:
> Hello,
>
>
>
> I downloaded the new version but now I have a problem with the
> configuration step of the new version.
>
>
>
> checking libical/ical.h usability... no
> checking libical/ical.h presence... no
> checking for libical/ical.h... no
> checking ical.h usability... no
> checking ical.h presence... no
> checking for ical.h... no
> configure: error: ical.h not found. You must have libical >= 0.27
> installed.
> GNUmakefile:2: local.make: No such file or directory

This is your first problem : you should source GNUstep.h to configure your environment before anything else.

Thanks,
Philippe

Hello Philippe,

sorry it took me this time to answer, but I was busy getting acquainted with autotools and the ports system of FreeBSD. Progress is very slow...
--
Sourcing GNUstep.h, isn't that done with the command ". /usr/local/GNUstep/System/Library/Makefiles/GNUstep.sh" in my .bashrc file?


Kind regards,


_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

edwin ancaer
In reply to this post by Riccardo Mottola-5

2018-07-12 22:58 GMT+02:00 Riccardo Mottola <[hidden email]>:
Hi,

On 2018-07-12 10:09:04 +0000 Ivan Vučica <[hidden email]> wrote:

> Did this help?
>
> If not, a hacky thing I would do is, I would try:
>   CFLAGS="-isystem /usr/local/include" ./configure
> instead.
>
> (Possibly also CXXFLAGS, OBJCFLAGS, and set up a library search path
> with -L/usr/local/lib in LDFLAGS as well.)
> On Thu, Jun 28, 2018 at 10:01 AM <[hidden email]> wrote:

I just tried myself building SimpleAgenda on FreeBSD.

it states:
  --with-ical-include=DIR include path for ical headers
  --with-ical-library=DIR library path for ical libraries

but they do not work, I fixed the configure.ac script to properly work.
Philippe, do you like it? please apply it!

One may criticize that this is not an "optional package" configuration, since ical is required and we are abusing of AC_ARG_WITH, however, at least it works.
Maybe there is a more proper AC macro?

Also, I format the help string correctly now.

Riccardo

<ical_opts.patch>

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep


Hello all,

Ivans 'hacky' solution gets me past the ./configure, but the following gmake command is giving copiler errors, so I probably need some more options changed.

I will try to apply the patch of Riccardo and see if the --libical options get me any further. I had already tried them, but as my knowledge of autotools  is verly limited, I did not think the problem could be in the script.


Thanks for helping,

Edwin Ancaer


_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

Yavor Doganov-3
In reply to this post by Riccardo Mottola-5
В Thu, 12 Jul 2018 22:58:59 +0200, Riccardo Mottola написа:
> On 2018-07-12 10:09:04 +0000 Ivan Vučica <[hidden email]> wrote:
>
>> If not, a hacky thing I would do is, I would try:
>>   CFLAGS="-isystem /usr/local/include" ./configure
>> instead.

Or better:

  ./configure CPPFLAGS=-I/usr/local/include

> I just tried myself building SimpleAgenda on FreeBSD.
>
> it states:
>   --with-ical-include=DIR include path for ical headers
>   --with-ical-library=DIR library path for ical libraries
>
> but they do not work,

Most probably it doesn't work because of this:

> -AC_ARG_WITH(ical-include, [  --with-ical-include=DIR  include path for
> ical headers], additional_include_dir+=-I"$withval", )
                                       ^^
That's a so called "bashism" and I suspect the default shell on FreeBSD
is not GNU Bash.

What troubles me most is that /usr/local/include is standard and is in
the search path of both GCC and Clang, at least on GNU/Linux.  You
shouldn't have to do anything special if libical is installed in /usr/
local.


_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

Riccardo Mottola-5
Hi,

Yavor Doganov wrote:
> That's a so called "bashism" and I suspect the default shell on FreeBSD
> is not GNU Bash.

exactly, same as other systems.
It is not needed and can be replaced with = as well as some "quoting" in []

>
> What troubles me most is that /usr/local/include is standard and is in
> the search path of both GCC and Clang, at least on GNU/Linux.  You
> shouldn't have to do anything special if libical is installed in/usr/
> local.

I don't know if FreeBSD is different here or there are other subtleties,
however the patch I supplied works fine for me in FreeBSD.
Only includes are needed, the library gets found in /usr/local

using AC_ARG_WITH may make some systems that scan automaticall
configures "believe" there is an optional dependency which is not true:
ical is a hard dep from what i can see.

Riccardo


_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

p.o.roussel
In reply to this post by Riccardo Mottola-5
Hi all,

On Thu, Jul 12, 2018 at 10:58:59PM +0200, Riccardo Mottola wrote:

> Hi,
>
> On 2018-07-12 10:09:04 +0000 Ivan Vučica <[hidden email]> wrote:
>
> > Did this help?
> >
> > If not, a hacky thing I would do is, I would try:
> >   CFLAGS="-isystem /usr/local/include" ./configure
> > instead.
> >
> > (Possibly also CXXFLAGS, OBJCFLAGS, and set up a library search path
> > with -L/usr/local/lib in LDFLAGS as well.)
> > On Thu, Jun 28, 2018 at 10:01 AM <[hidden email]> wrote:
>
> I just tried myself building SimpleAgenda on FreeBSD.
>
> it states:
>   --with-ical-include=DIR include path for ical headers
>   --with-ical-library=DIR library path for ical libraries
>
> but they do not work, I fixed the configure.ac script to properly work.
> Philippe, do you like it? please apply it!

If it fixes a bug I love it :o) And I'll trust you on autoconf stuff
as on many others.

I'll apply your patch and push out.

Thanks a lot,
Philippe
--
What's tan and black and looks great on a lawyer? A doberman.


_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

edwin ancaer


2018-07-15 13:16 GMT+02:00 Philippe Roussel <[hidden email]>:
Hi all,

On Thu, Jul 12, 2018 at 10:58:59PM +0200, Riccardo Mottola wrote:
> Hi,
>
> On 2018-07-12 10:09:04 +0000 Ivan Vučica <[hidden email]> wrote:
>
> > Did this help?
> >
> > If not, a hacky thing I would do is, I would try:
> >   CFLAGS="-isystem /usr/local/include" ./configure
> > instead.
> >
> > (Possibly also CXXFLAGS, OBJCFLAGS, and set up a library search path
> > with -L/usr/local/lib in LDFLAGS as well.)
> > On Thu, Jun 28, 2018 at 10:01 AM <[hidden email]> wrote:
>
> I just tried myself building SimpleAgenda on FreeBSD.
>
> it states:
>   --with-ical-include=DIR include path for ical headers
>   --with-ical-library=DIR library path for ical libraries
>
> but they do not work, I fixed the configure.ac script to properly work.
> Philippe, do you like it? please apply it!

If it fixes a bug I love it :o) And I'll trust you on autoconf stuff
as on many others.

I'll apply your patch and push out.

Thanks a lot,
Philippe
--
What's tan and black and looks great on a lawyer? A doberman.


_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep

Hello guys,

with the correction suggested by Riccardo anf Yavor, I managed to compile SimplaAgenda.

However, when linking I get the error

2 warnings generated.
 Linking app SimpleAgenda ...
 Creating SimpleAgenda.app/Resources...
 Creating stamp file...
 Creating SimpleAgenda.app/Resources/Info-gnustep.plist...
Shared object "libgnustep-base.so.1.24" not found, required by "plmerge"
gmake[2]: [/usr/local/GNUstep/System/Library/Makefiles/Instance/application.make:282: SimpleAgenda.app/Resources/Info-gnustep.plist] Error 1 (ignored)
 Creating SimpleAgenda.app/Resources/SimpleAgenda.desktop...
 Copying resources into the app wrapper...
 Copying localized resources into the app wrapper...

I've got version 1.25 installled, so where does that 1.24 comes from?

Thanks again,


_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

Ivan Vučica-2
Presumably from an old 'plmerge' left over from a previous
installation of gnustep-base. If you type in 'which plmerge', you'll
find out which 'plmerge' binary is being used. Nuke it and ensure that
only the latest 'plmerge' is being used. For instance, if it's in
/usr/bin, it may have come from your {OS,distribution}'s package
manager, in which case you should uninstall the corresponding package;
if it's elsewhere, or you are certain it's not from a package, then rm
it.
On Mon, Jul 16, 2018 at 2:05 AM Edwin Ancaer <[hidden email]> wrote:

>
>
>
> 2018-07-15 13:16 GMT+02:00 Philippe Roussel <[hidden email]>:
>>
>> Hi all,
>>
>> On Thu, Jul 12, 2018 at 10:58:59PM +0200, Riccardo Mottola wrote:
>> > Hi,
>> >
>> > On 2018-07-12 10:09:04 +0000 Ivan Vučica <[hidden email]> wrote:
>> >
>> > > Did this help?
>> > >
>> > > If not, a hacky thing I would do is, I would try:
>> > >   CFLAGS="-isystem /usr/local/include" ./configure
>> > > instead.
>> > >
>> > > (Possibly also CXXFLAGS, OBJCFLAGS, and set up a library search path
>> > > with -L/usr/local/lib in LDFLAGS as well.)
>> > > On Thu, Jun 28, 2018 at 10:01 AM <[hidden email]> wrote:
>> >
>> > I just tried myself building SimpleAgenda on FreeBSD.
>> >
>> > it states:
>> >   --with-ical-include=DIR include path for ical headers
>> >   --with-ical-library=DIR library path for ical libraries
>> >
>> > but they do not work, I fixed the configure.ac script to properly work.
>> > Philippe, do you like it? please apply it!
>>
>> If it fixes a bug I love it :o) And I'll trust you on autoconf stuff
>> as on many others.
>>
>> I'll apply your patch and push out.
>>
>> Thanks a lot,
>> Philippe
>> --
>> What's tan and black and looks great on a lawyer? A doberman.
>>
>>
>> _______________________________________________
>> Discuss-gnustep mailing list
>> [hidden email]
>> https://lists.gnu.org/mailman/listinfo/discuss-gnustep
>
>
> Hello guys,
>
> with the correction suggested by Riccardo anf Yavor, I managed to compile SimplaAgenda.
>
> However, when linking I get the error
>
> 2 warnings generated.
>  Linking app SimpleAgenda ...
>  Creating SimpleAgenda.app/Resources...
>  Creating stamp file...
>  Creating SimpleAgenda.app/Resources/Info-gnustep.plist...
> Shared object "libgnustep-base.so.1.24" not found, required by "plmerge"
> gmake[2]: [/usr/local/GNUstep/System/Library/Makefiles/Instance/application.make:282: SimpleAgenda.app/Resources/Info-gnustep.plist] Error 1 (ignored)
>  Creating SimpleAgenda.app/Resources/SimpleAgenda.desktop...
>  Copying resources into the app wrapper...
>  Copying localized resources into the app wrapper...
>
> I've got version 1.25 installled, so where does that 1.24 comes from?
>
> Thanks again,
>

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

edwin ancaer
Hello again,

Just to say that everything is working now. Ons minor remark, in the attached screeshot, you will see that the hours and durations miss 1 digit when all 5 positions are needed. Is that something I can update  with some settings, or is it for a future release 😁?

Next step is to get the new version installed with the ports system of FreeBSD.


Thanks for helping,

Edwin Ancaer



Op ma 16 jul. 2018 12:22 schreef Ivan Vučica <[hidden email]>:
Presumably from an old 'plmerge' left over from a previous
installation of gnustep-base. If you type in 'which plmerge', you'll
find out which 'plmerge' binary is being used. Nuke it and ensure that
only the latest 'plmerge' is being used. For instance, if it's in
/usr/bin, it may have come from your {OS,distribution}'s package
manager, in which case you should uninstall the corresponding package;
if it's elsewhere, or you are certain it's not from a package, then rm
it.
On Mon, Jul 16, 2018 at 2:05 AM Edwin Ancaer <[hidden email]> wrote:
>
>
>
> 2018-07-15 13:16 GMT+02:00 Philippe Roussel <[hidden email]>:
>>
>> Hi all,
>>
>> On Thu, Jul 12, 2018 at 10:58:59PM +0200, Riccardo Mottola wrote:
>> > Hi,
>> >
>> > On 2018-07-12 10:09:04 +0000 Ivan Vučica <[hidden email]> wrote:
>> >
>> > > Did this help?
>> > >
>> > > If not, a hacky thing I would do is, I would try:
>> > >   CFLAGS="-isystem /usr/local/include" ./configure
>> > > instead.
>> > >
>> > > (Possibly also CXXFLAGS, OBJCFLAGS, and set up a library search path
>> > > with -L/usr/local/lib in LDFLAGS as well.)
>> > > On Thu, Jun 28, 2018 at 10:01 AM <[hidden email]> wrote:
>> >
>> > I just tried myself building SimpleAgenda on FreeBSD.
>> >
>> > it states:
>> >   --with-ical-include=DIR include path for ical headers
>> >   --with-ical-library=DIR library path for ical libraries
>> >
>> > but they do not work, I fixed the configure.ac script to properly work.
>> > Philippe, do you like it? please apply it!
>>
>> If it fixes a bug I love it :o) And I'll trust you on autoconf stuff
>> as on many others.
>>
>> I'll apply your patch and push out.
>>
>> Thanks a lot,
>> Philippe
>> --
>> What's tan and black and looks great on a lawyer? A doberman.
>>
>>
>> _______________________________________________
>> Discuss-gnustep mailing list
>> [hidden email]
>> https://lists.gnu.org/mailman/listinfo/discuss-gnustep
>
>
> Hello guys,
>
> with the correction suggested by Riccardo anf Yavor, I managed to compile SimplaAgenda.
>
> However, when linking I get the error
>
> 2 warnings generated.
>  Linking app SimpleAgenda ...
>  Creating SimpleAgenda.app/Resources...
>  Creating stamp file...
>  Creating SimpleAgenda.app/Resources/Info-gnustep.plist...
> Shared object "libgnustep-base.so.1.24" not found, required by "plmerge"
> gmake[2]: [/usr/local/GNUstep/System/Library/Makefiles/Instance/application.make:282: SimpleAgenda.app/Resources/Info-gnustep.plist] Error 1 (ignored)
>  Creating SimpleAgenda.app/Resources/SimpleAgenda.desktop...
>  Copying resources into the app wrapper...
>  Copying localized resources into the app wrapper...
>
> I've got version 1.25 installled, so where does that 1.24 comes from?
>
> Thanks again,
>

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep

Screenshot_20180717-100830.png (2M) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: SimpleAgenda on FreeBSD

edwin ancaer
Sorry for the wrong screenshot. Apparently no recall in Gmail.  Here is the correct one:

Op di 17 jul. 2018 11:50 schreef Edwin Ancaer <[hidden email]>:
Hello again,

Just to say that everything is working now. Ons minor remark, in the attached screeshot, you will see that the hours and durations miss 1 digit when all 5 positions are needed. Is that something I can update  with some settings, or is it for a future release 😁?

Next step is to get the new version installed with the ports system of FreeBSD.


Thanks for helping,

Edwin Ancaer



Op ma 16 jul. 2018 12:22 schreef Ivan Vučica <[hidden email]>:
Presumably from an old 'plmerge' left over from a previous
installation of gnustep-base. If you type in 'which plmerge', you'll
find out which 'plmerge' binary is being used. Nuke it and ensure that
only the latest 'plmerge' is being used. For instance, if it's in
/usr/bin, it may have come from your {OS,distribution}'s package
manager, in which case you should uninstall the corresponding package;
if it's elsewhere, or you are certain it's not from a package, then rm
it.
On Mon, Jul 16, 2018 at 2:05 AM Edwin Ancaer <[hidden email]> wrote:
>
>
>
> 2018-07-15 13:16 GMT+02:00 Philippe Roussel <[hidden email]>:
>>
>> Hi all,
>>
>> On Thu, Jul 12, 2018 at 10:58:59PM +0200, Riccardo Mottola wrote:
>> > Hi,
>> >
>> > On 2018-07-12 10:09:04 +0000 Ivan Vučica <[hidden email]> wrote:
>> >
>> > > Did this help?
>> > >
>> > > If not, a hacky thing I would do is, I would try:
>> > >   CFLAGS="-isystem /usr/local/include" ./configure
>> > > instead.
>> > >
>> > > (Possibly also CXXFLAGS, OBJCFLAGS, and set up a library search path
>> > > with -L/usr/local/lib in LDFLAGS as well.)
>> > > On Thu, Jun 28, 2018 at 10:01 AM <[hidden email]> wrote:
>> >
>> > I just tried myself building SimpleAgenda on FreeBSD.
>> >
>> > it states:
>> >   --with-ical-include=DIR include path for ical headers
>> >   --with-ical-library=DIR library path for ical libraries
>> >
>> > but they do not work, I fixed the configure.ac script to properly work.
>> > Philippe, do you like it? please apply it!
>>
>> If it fixes a bug I love it :o) And I'll trust you on autoconf stuff
>> as on many others.
>>
>> I'll apply your patch and push out.
>>
>> Thanks a lot,
>> Philippe
>> --
>> What's tan and black and looks great on a lawyer? A doberman.
>>
>>
>> _______________________________________________
>> Discuss-gnustep mailing list
>> [hidden email]
>> https://lists.gnu.org/mailman/listinfo/discuss-gnustep
>
>
> Hello guys,
>
> with the correction suggested by Riccardo anf Yavor, I managed to compile SimplaAgenda.
>
> However, when linking I get the error
>
> 2 warnings generated.
>  Linking app SimpleAgenda ...
>  Creating SimpleAgenda.app/Resources...
>  Creating stamp file...
>  Creating SimpleAgenda.app/Resources/Info-gnustep.plist...
> Shared object "libgnustep-base.so.1.24" not found, required by "plmerge"
> gmake[2]: [/usr/local/GNUstep/System/Library/Makefiles/Instance/application.make:282: SimpleAgenda.app/Resources/Info-gnustep.plist] Error 1 (ignored)
>  Creating SimpleAgenda.app/Resources/SimpleAgenda.desktop...
>  Copying resources into the app wrapper...
>  Copying localized resources into the app wrapper...
>
> I've got version 1.25 installled, so where does that 1.24 comes from?
>
> Thanks again,
>

_______________________________________________
Discuss-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/discuss-gnustep

20180717_084659.jpg (1M) Download Attachment
12