Vespucci and Flexisheet : Webkit deprecated dependencies ?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Vespucci and Flexisheet : Webkit deprecated dependencies ?

GNUstep - General mailing list
Hi All,

I tried to make some apps from the Gap repository.
While building Vespucci and Flexisheet, I was stuck with a dependency
I could not resolve : it seems to be a deprecated Webkit lib, because
the alternative Debian gave (1) was not usefull :

Making all for app Vespucci...
  Compiling file VEWinController.m ...
In file included from VEWinController.m:26:
VEWinController.h:27:9: fatal error: WebKit/WebPreferences.h: Aucun
fichier ou dossier de ce type
  #import <WebKit/WebPreferences.h>
          ^~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[3]: *** [/usr/share/GNUstep/Makefiles/rules.make:479:
obj/Vespucci.obj/VEWinController.m.o] Error 1
make[2]: ***
[/usr/share/GNUstep/Makefiles/Instance/application.make:147:
internal-app-run-compile-submake] Error 2
make[1]: *** [/usr/share/GNUstep/Makefiles/Master/rules.make:297:
Vespucci.all.app.variables] Error 2
make: *** [/usr/share/GNUstep/Makefiles/Master/application.make:38:
internal-all] Error 2

And also with Flexisheet :

Making all for subproject Application...
  Compiling file FSFunctionHelp.m ...
FSFunctionHelp.m:13:9: fatal error: WebKit/WebView.h: Aucun fichier ou
dossier de ce type
  #import <WebKit/WebView.h>
          ^~~~~~~~~~~~~~~~~~
compilation terminated.
make[4]: *** [/usr/share/GNUstep/Makefiles/rules.make:479:
obj/Application.obj/FSFunctionHelp.m.o] Error 1
make[3]: ***
[/usr/share/GNUstep/Makefiles/Instance/subproject.make:45:
internal-subproject-all_] Error 2
make[2]: *** [/usr/share/GNUstep/Makefiles/Master/rules.make:297:
Application.all.subproject.variables] Error 2
make[1]: *** [/usr/share/GNUstep/Makefiles/Master/rules.make:297:
FlexiSheet.all.app.variables] Error 2
make: *** [/usr/share/GNUstep/Makefiles/Master/application.make:38:
internal-all] Error 2

(1) Debian apt installer propose to install the alternative :
  libwebkitgtk-dev and libjavascriptcoregtk-1.0-dev
but these libraries don't provide the needed headers.

Regards,

--
Bien cordialement,
Patrick CARDONA


Reply | Threaded
Open this post in threaded view
|

Re: Vespucci and Flexisheet : Webkit deprecated dependencies ?

Riccardo Mottola-5
Hi Patrick,


On 12/06/2020 00:47, Patrick Cardona via Discussion list for the GNUstep
programming environment wrote:
> I tried to make some apps from the Gap repository.
> While building Vespucci and Flexisheet, I was stuck with a dependency
> I could not resolve : it seems to be a deprecated Webkit lib, because
> the alternative Debian gave (1) was not usefull :


it means you miss WebKit. Currently the only way to satisfy it is
libs-simplewebkit which was never released because alpha-quality.

For Flexisheet, this is not a big issue, the library is only needed to
display some Help.

Vespucci is a rudimentary browser which is essentially testbed for SWK
itself.

About the only useful thing you can do now is browse the Reference
documentation without kicking up Firefox. Useful if you are on a
Raspberry or other similar system, but not much more.


don't hold your breath though, SWK is stagnant since years, unfortunately.


A port of WebKit however would be a "drop-in", the interfaces are the same.


Riccardo


Reply | Threaded
Open this post in threaded view
|

Re: Vespucci and Flexisheet : Webkit deprecated dependencies ?

GNUstep - General mailing list
Hi Riccardo,


On 2020-06-12 01:45:03 +0200 Riccardo Mottola
<[hidden email]> wrote:

> Hi Patrick,
>
>
> On 12/06/2020 00:47, Patrick Cardona via Discussion list for the
> GNUstep
> programming environment wrote:
>> I tried to make some apps from the Gap repository.
>> While building Vespucci and Flexisheet, I was stuck with a
>> dependency I
>> could not resolve : it seems to be a deprecated Webkit lib, because
>> the
>> alternative Debian gave (1) was not us
>
>
> it means you miss WebKit. Currently the only way to satisfy it is
> libs-simplewebkit which was never released because alpha-quality.
>
> For Flexisheet, this is not a big issue, the library is only needed
> to
> display some Help.

So I removed the header calls about FSFunctionHelp in the GNUmakefile
and even in other headers where it was named, and I could make the
FlexiSheet app.
Thank You for your help.

>
> Vespucci is a rudimentary browser which is essentially testbed for
> SWK itself.
>
> About the only useful thing you can do now is browse the Reference
> documentation without kicking up Firefox. Useful if you are on a
> Raspberry or
> other similar system, but not much more.

So I shall not try about Vespucci  anymore.

>
>
> don't hold your breath though, SWK is stagnant since years,
> unfortunately.
>
>
> A port of WebKit however would be a "drop-in", the interfaces are the
> same.
>
>
> Riccardo
>
>

Regards
--
Bien cordialement,
Patrick CARDONA


Reply | Threaded
Open this post in threaded view
|

Re: Vespucci and Flexisheet : Webkit deprecated dependencies ?

Riccardo Mottola-5
Hi,

Patrick Cardona via Discussion list for the GNUstep programming
environment wrote:
> So I removed the header calls about FSFunctionHelp in the GNUmakefile
> and even in other headers where it was named, and I could make the
> FlexiSheet app.
> Thank You for your help.
>

Possible hack,you can also install libs-simplebwekit from sources.
Never being released, it is reasonable that it is not present in Debian
or Raspbian.


>>
>> Vespucci is a rudimentary browser which is essentially testbed for SWK
>> itself.
>>
>> About the only useful thing you can do now is browse the Reference
>> documentation without kicking up Firefox. Useful if you are on a
>> Raspberry or other similar system, but not much more.
>
> So I shall not try about Vespucci  anymore.


well, you can play with it.. but not of much use. For our documentation
it is good enough! For more, patches needed :-P Just wanted to false hopes.

Although it prompted me to make a micro-fix to SWK since a lont time!

Riccardo