[bug #53080] NSPortMessage msgid is ignored when sending the message

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[bug #53080] NSPortMessage msgid is ignored when sending the message

dsdsdsds
URL:
  <http://savannah.gnu.org/bugs/?53080>

                 Summary: NSPortMessage msgid is ignored when sending the
message
                 Project: GNUstep
            Submitted by: yavor
            Submitted on: Wed 07 Feb 2018 12:44:50 AM EET
                Category: Base/Foundation
                Severity: 3 - Normal
              Item Group: Bug
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
         Discussion Lock: Any

    _______________________________________________________

Details:

While porting Lynkeos I noticed that the value of the NSPortMessage _msgid
ivar is ignored when the message is being sent.  The current Base behavior is
raising an exception in Lynkeos because its -handlePortMessage: implementation
expects messages to have certain msgids while all messages are sent with msgid
0, despite the fact that -setMsgid: is sent on the newly created instances to
set a different msgid.

The attached trivial patch fixes it for me.  (BTW, this ivar is declared as
unsigned while the NSPort method expects NSInteger.)



    _______________________________________________________

File Attachments:


-------------------------------------------------------
Date: Wed 07 Feb 2018 12:44:50 AM EET  Name: msgid.patch  Size: 1KiB   By:
yavor

<http://savannah.gnu.org/bugs/download.php?file_id=43196>

    _______________________________________________________

Reply to this item at:

  <http://savannah.gnu.org/bugs/?53080>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.gnu.org/


_______________________________________________
Bug-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-gnustep
Reply | Threaded
Open this post in threaded view
|

[bug #53080] NSPortMessage msgid is ignored when sending the message

dsdsdsds
Update of bug #53080 (project gnustep):

                  Status:                    None => Fixed                  
             Open/Closed:                    Open => Closed                

    _______________________________________________________

Follow-up Comment #1:

Thanks a lot ... patch applied.

    _______________________________________________________

Reply to this item at:

  <http://savannah.gnu.org/bugs/?53080>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.gnu.org/


_______________________________________________
Bug-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-gnustep