linking fails / icon broken in window maker / gorm

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

linking fails / icon broken in window maker / gorm

Gürkan Sengün-3
Hi

I have reported this bug report against WindowMaker, however I'm not
sure if it's their fault or GNUsteps'
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=908512

When I try to build ModPlugPlay.app (to link it against
libopenmpt-modplug-dev+libao-dev instead libmodplug-dev),
I'm getting linking errors like:

# gs_make
This is gnustep-make 2.7.0. Type 'make print-gnustep-make-help' for
help.
Making all for app ModPlugPlay...
  Linking app ModPlugPlay ...
/usr/bin/ld: ./obj/ModPlugPlay.obj/main.m.o: in function `main':
/home/alex/debian/ModPlugPlay.app/ModPlugPlay.app-1.8/main.m:37:
undefined reference to `ModPlug_GetSettings'
/usr/bin/ld: ./obj/ModPlugPlay.obj/Controller.m.o: in function
`_i_Controller__forward_':
/home/alex/debian/ModPlugPlay.app/ModPlugPlay.app-1.8/Controller.m:247:
undefined reference to `ModPlug_Seek'
/usr/bin/ld: ./obj/ModPlugPlay.obj/Controller.m.o: in function
`_i_Controller__backward_':
/home/alex/debian/ModPlugPlay.app/ModPlugPlay.app-1.8/Controller.m:258:
undefined reference to `ModPlug_Seek'
/usr/bin/ld: ./obj/ModPlugPlay.obj/Controller.m.o: in function
`_i_Controller__continuePlay':
/home/alex/debian/ModPlugPlay.app/ModPlugPlay.app-1.8/Controller.m:276:
undefined reference to `ModPlug_Read'
/usr/bin/ld:
/home/alex/debian/ModPlugPlay.app/ModPlugPlay.app-1.8/Controller.m:277:
undefined reference to `ao_play'
/usr/bin/ld: ./obj/ModPlugPlay.obj/Controller.m.o: in function
`_i_Controller__nextSong_':
/home/alex/debian/ModPlugPlay.app/ModPlugPlay.app-1.8/Controller.m:85:
undefined reference to `ModPlug_Unload'

You can find the source to retry at:
https://github.com/alexmyczko/ModPlugPlay.app

I'm also having troubles with the resources (no matter wether they are
.tiff or .png, they get displayed wrong/not in
Gorm)

Best,

_______________________________________________
Bug-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-gnustep
Reply | Threaded
Open this post in threaded view
|

Re: linking fails / icon broken in window maker / gorm

Yavor Doganov-3
В Sun, 16 Sep 2018 16:26:57 +0200, Gürkan Myczko написа:

> When I try to build ModPlugPlay.app (to link it against
> libopenmpt-modplug-dev+libao-dev instead libmodplug-dev),
> I'm getting linking errors like:

Check your makefile:  ADDITIONAL_LDFLAGS should be ADDITIONAL_GUI_LIBS or
ModPlugPlay_GUI_LIBS.

I'm not familiar with the details but I wonder why would you want to link
with a library that provides a compatibility layer around another library
instead of the real library itself?


_______________________________________________
Bug-gnustep mailing list
[hidden email]
https://lists.gnu.org/mailman/listinfo/bug-gnustep